vSphere Web Client Plugin

vSphere Web Client Plugin

The Pure Storage Plugin is stored on the FlashArray controllers and new versions are included with Purity upgrades. If a new version is desired and a Purity upgrade is not, contact support for the new plugin version.

Configuration:

Version 2 Video Demo:

*****Purity 4.7+ requires TLS 1.1 and 1.2 support, only vCenter 6.0 U2+ and vCenter 6.5+ support this by default. For Windows-based vCenters, TLS can be upgraded, but for vCenter Linux Appliance (VCSA) it is not supported by VMware to do so. For VCSA users, please upgrade to vCenter 6.0U2 or later if you are running Purity 4.7+ and you want to use the plugin.*****

See this VMware KB for more information on TLS support in VMware products

Status of TLSv1.1/1.2 Enablement and TLSv1.0 Disablement across VMware products

Plugin Support Matrix:

PLUGIN VERSION VCENTER VERSION PURITY VERSION SUPPORTED INCLUDED IN WHAT PURITY VERSIONS COMMENTS
2.0.0 5.1 (all updates), 5.5 (all updates) 4.0.x through 4.6.x 4.1.1-4.1.2
2.0.10 5.1 (all updates), 5.5 (all updates), 6.0 (GA through U1) 4.0.x through 4.7.x 4.5.15-4.7.2  TLS 1.1 support added.
2.1.0 5.1 (all updates), 5.5 (all updates), 6.0 (GA through U2) 4.0.x through 4.9.x 4.7.3-4.8.6   First version to support 6.0 U2+. Last version of plugin to support vSphere 5.1.
2.5.0 5.5 (all updates), 6.0 (GA through U2) 4.0.x through 4.9.x 4.9.0+ No longer support vSphere 5.1

NOTE: There are some builds missing as they are patch builds. If you are running those versions refer to Pure Storage support for compatibility.

 

 

"Remember kids, the only difference between Science and screwing around is writing it down"