As I have blogged about before, TLS 1.0 and SSL v3 were deprecated in Purity 4.7, requiring all connections to use either TLS 1.1 or TLS 1.2. This affected a variety of integrations, some we updated, some you just had to alter their behavior. A few VMware products do not/did not use TLS 1.1/1.2 by default, so they either need to altered or upgraded. This almost invariably boiled down to the JDK version that was in use. vRealize Orchestrator is no exception.
I wrote about some security changes in the FlashArray operating environment (called Purity) version 4.7 a month or so back. This was concerning the deprecation of SSL and TLS version 1.0, forcing all (management) connections to the FlashArray to use TLS 1.1 or 1.2 (read this here).
Our PowerShell SDK was enhanced so it would use the appropriate security connection type so users of that do not need to worry as long as they upgrade our SDK. But what about the few remaining functions that people might use that the PowerShell SDK doesn’t cover? As there are a few REST calls that are not built into the SDK (yet). Continue reading “Force the Invoke-RestMethod PowerShell cmdlet to use TLS 1.2”
In the recent release of the Purity Operating Environment on the FlashArray we deprecated TLS 1.0 support due to the ever growing list of vulnerabilities in it. Communication will be restricted to TLS 1.1 and later. Unfortunately, this affects some plugins/integrations. This is not an exhaustive list, but related to the ones VMware customers probably touch the most. If something is not listed ping the relevant support organization for more information.
The following plugins are NOT affected and will continue to work with Purity 4.7:
- vRealize Operations Management Pack
- vRealize Orchestrator Workflow Package
- vRealize Log Insight Content Pack
The following are affected and will need to be upgraded to a specific version to work with Purity 4.7:
- Site Recovery Manager Storage Replication Adapter (this needs to be version 1.5, which will be out soon)
- vSphere Web Client Plugin (this needs to be version 2.0.10+)
- VSS Provider (this needs to be version 1.0.2)
- PowerShell SDK (this needs to be version 1.5)